Page 1 of 15 12311 ... LastLast
Results 1 to 10 of 144
  1. #1

    Zhao's Avatar
    Join Date
    Jan 2012
    HRP Name
    Zhao Yhang
    Posts
    5,786

    Sync / lag issues

    NOTE: If you are not affected by any lag in-game then you can ignore this post. This is mainly directed at the people who do have sync / lag issues.

    ---

    What's the problem?

    As many of you are already aware we have been having sync / lag issues on the server and despite numerous efforts we have been unable to resolve it. Over the course of the last year and a half I overhauled the script and optimized a lot of things to make it run faster, and for a while it did appear to be making a difference, but this issue keeps coming back.

    I even consulted with the SA-MP team to see if we could get to the bottom of it, and after having overhauled nearly the entire script and optimizing every last thing I could think of to make the server run faster, I was almost certain that the issue would come to an end, but it has not.

    We've been pulling out our hairs over this issue as nothing seems to do the trick. We've tried moving the server across the ocean, upgraded the server hardware, made script adjustments, reinstalled everything on a blank / fresh server, conducted tests with players (both in-game and through third-party programs), tried collecting network data from players and nothing has pointed us to the root of the problem.

    The amount of time I have put into trying to fix this is absolutely ridiculous. This is an issue that has been plaguing our community for quite some time now, and just like many of you we've really had enough of it. This is our number one priority right now.


    What's going to happen now?

    At this point I've contacted our host and told them that I've tried everything on our end to fix the issue, and given them 72 hours to figure out what the problem is and give us a term for when it will be fixed. If they are unable to do so and continue claiming the issue is not with them, then we will be moving to an entirely different host as soon as possible to find out whether that will make a difference. Such a switch would be purely experimental to find out whether it affects the lag issues, but if it does then we will remain with the new host.

    ---

    As always, we deeply appreciate your continued loyalty to the community and your patience with this and any other problems our community has faced over the years. We will do our very best to put an end to this problem once and for all.

    This post will be adjusted if there are any updates on the situation.



    EDIT (APRIL 26): Our host has been unable to provide us with a solution and claims not to have been able to find an issue on their end. As the 72 hour term we gave them has ran out, we have responded by saying we will test their claim by trying to run our server at another host. More news will follow about the exact date we try this switch and whether we will remain with a new host.


    EDIT #2 (APRIL 28): We've obtained a new server at a different host and have started configuring everything today. Sometime this weekend the SA-MP server will be transferred over to the new host in order to conduct the test and find out whether it will put an end to this issue.


    EDIT #3 (APRIL 29): We have just taken the server offline to start the transfer to the new host. We have no exact approximation for how long this will take, but updates on the progress will be posted in this thread.


    EDIT #4: The transfer to the new host has just been completed. We have most to an entirely different host and the server is located in Europe (France), which is the reason for the difference in pings, but it should not make a significant impact with our scripted sync shooting. Please note that this is still experimental, and we are merely trying to figure out whether this will fix the lag issues.


    EDIT #5: The TeamSpeak server has also been transferred to the new host. Some services like the UCP and highscores have not been linked to the new server yet, so they may be down or display old information. We are happy to report that many players have given nothing but positive feedback so far. It appears to have addressed the issue, but we will continue monitoring the situation and conduct tests with higher player counts. More information and details will follow in an upcoming announcement.


    Those with issues connecting to the server are advised to try the following:

    1. Close GTA-SA.exe (if you still have it open) and restart the SA-MP client.

    2. Remove us from your favorites tab on the SA-MP client then re-add samp.hzgaming.net:7777

    3. Flush your DNS by clicking here and following the guide

    4. Use Google DNS to resolve the changes faster by clicking here and following the guide

    Or you can wait a little while and try again later, then it should work when the DNS changes have pushed out to you.

    Contact Information:
    Forum PM: Click here
    E-mail: [email protected]

  2. #2

    David's Avatar
    Join Date
    Jan 2013
    Location
    Georgia, tbilisi
    Posts
    2,307
    Well I don't know what's the problem since I don't have any experience towards it but we have some bad lag on point/turfs, even if there is like some bunch of players standing together, it's fucked up it's even dropping the fps, no idea what's the problem but it obviously should be fixed otherwise we will lose playerbase.
    Last edited by David; April 23rd, 2017 at 05:00 PM.
    How to be crybaby


    >>>>>>>>><<<<<<<<<

  3. #3

    Join Date
    Jun 2016
    HRP Name
    Alex Powers
    Posts
    96
    FINALLY

  4. #4
    Derek Rayleigh's Avatar
    Join Date
    Oct 2016
    Location
    Tunisia
    Posts
    751
    Nice

  5. #5

    Zhao's Avatar
    Join Date
    Jan 2012
    HRP Name
    Zhao Yhang
    Posts
    5,786
    Quote Originally Posted by David View Post
    Well I don't know what's the problem since I don't have any experience towards it but we have some bad lag on point/turfs, even if there is like some bunch of players standing together, it's fucked up it's even dropping the fps, no idea what's the problem but it obviously should be fixed otherwise we will lose playerbase.
    FPS issues are client-related, so we can't really do a whole lot about that. This is in regards to the connection issues, which are a server-related issue (in this instance anyway, there are also plenty of instances where it can be client-related).

    Contact Information:
    Forum PM: Click here
    E-mail: [email protected]

  6. #6

    Kenny's Avatar
    Join Date
    Jan 2013
    HRP Name
    Kenny Ghetto
    Location
    Georgia
    Posts
    4,103
    Okay
    Sup bitches

  7. #7

    Shaun's Avatar
    Join Date
    Feb 2014
    HRP Name
    shauM
    Location
    Crane, Ocean Docks
    Posts
    1,410
    You just need to upgrade or renew the host and we all gucci

  8. #8

    David's Avatar
    Join Date
    Jan 2013
    Location
    Georgia, tbilisi
    Posts
    2,307
    Quote Originally Posted by Zhao View Post
    FPS issues are client-related, so we can't really do a whole lot about that. This is in regards to the connection issues, which are a server-related issue (in this instance anyway, there are also plenty of instances where it can be client-related).
    I understand but I've seen other servers bunch of people standing together and still FPS is normal, fps drops "sometimes" not always so it's not client-sided I think.
    How to be crybaby


    >>>>>>>>><<<<<<<<<

  9. #9

    Zhao's Avatar
    Join Date
    Jan 2012
    HRP Name
    Zhao Yhang
    Posts
    5,786
    Quote Originally Posted by David View Post
    I understand but I've seen other servers bunch of people standing together and still FPS is normal, fps drops "sometimes" not always so it's not client-sided I think.
    Those could be instances of a hacker causing it (there are several CLEOs to do that), but our admins take care of that fairly quickly, so it shouldn't last that long.

    We aren't doing anything unusual in the script that would cause your FPS to drop, so it is almost always a client-sided issue.

    Contact Information:
    Forum PM: Click here
    E-mail: [email protected]

  10. #10


    luke chicano's Avatar
    Join Date
    Jun 2012
    Location
    katakwi
    Posts
    2,651
    aws


Page 1 of 15 12311 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT. The time now is 12:16 AM.
Powered by vBulletin® Version 4.2.5
Copyright © 2018 vBulletin Solutions Inc. All rights reserved.
Extra Tabs by vBulletin Hispano